Saturday, 14 June 2014

Conky Manager v2 Released

Conky Manager v2 is now available. This is a major update with a completely revamped UI and options. A big thanks to everyone who contributed to this project.

User Manual

A complementary user manual is now available for all users who have contributed to this project either through donations or by translating the application to other languages. The manual has a detailed description of the functionality along with steps required for creating theme packs and for fixing common issues.

If you wish to receive a copy of the user manual please consider leaving a donation using the PayPal link below. A copy will be sent to you by email. If you have already donated to this project you do not need to donate again.

Installation

Ubuntu-based Distributions (Ubuntu, Linux Mint, etc)

If you are using Ubuntu or its derivatives (like Xubuntu, Linux Mint, etc) you can install it from the Launchpad PPA. Builds are available for the following Ubuntu releases:

  • 13.10 (saucy)
  • 14.04 (trusty)
  • 14.10 (utopic)

For any other release, you can install it using the DEB files given below.

conky-manager-latest-i386.deb (32-bit, 1 MB)
conky-manager-latest-amd64.deb (64-bit, 1 MB)

To install from PPA, type the following commands one by one in a terminal window:

sudo apt-add-repository -y ppa:teejee2008/ppa
sudo apt-get update
sudo apt-get install conky-manager

Updates will be installed automatically if you have enabled automatic updates enabled on your system. The package can also be updated manually by running the install command again.

sudo apt-get install conky-manager

Debian

The DEB files are available from following links:

conky-manager-latest-i386.deb (32-bit, 1 MB)
conky-manager-latest-amd64.deb (64-bit, 1 MB)

Other Linux Distributions

An installer is available from following links:

conky-manager-latest-i386.run (32-bit, 1 MB)
conky-manager-latest-amd64.run (64-bit, 1 MB)

Run it from a terminal window with the following commands:

sh ./conky-manager-latest-i386.run  #32-bit
sh ./conky-manager-latest-amd64.run  #64-bit

Depending on the distribution that you are using, you may need to install packages for the following dependencies:

libgtk-3 libgee2 libjson-glib rsync imagemagick p7zip

Theme Packs

The default installation contains only a few sample themes. For more themes, download the theme pack given below and install it using the Import button on the toolbar.

Official Theme Pack #1 (15 MB)

Donations

A big thanks to everyone who donated to this project.

DateNameAmountProject
2014-05-31Will Hartley $10 Conky Manager v2
2014-04-27Steven Klausmeier $10 Conky Manager v2
2014-04-26Radek Otahal $10 Conky Manager v2
2014-04-21Gus Chavez $10 Conky Manager v2
2014-04-19Adam Simmons $10 Conky Manager v2
2014-04-08Raymond Shaffer $10 Conky Manager v2
2014-04-06Flaviu Dan $10 Conky Manager v2
2014-04-01Nicola Jelmorini $100 Conky Manager v2
2014-03-31Dan Raymond $10 Conky Manager v2
2014-03-19John Cruz $10 Conky Manager v2
2014-03-14William Keller $10 Conky Manager v2
2014-03-11Umut Baris Demir $10 Conky Manager v2
2014-02-26Jesse Avalos $20 Conky Manager v2


Disclaimer

This program is free for personal and commercial use and comes with absolutely no warranty. The author will not be liable for any damages arising from the use of this program.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
See the GNU General Public License for more details.

Support This Project

This application is free for personal and commercial use and is licensed under the GNU General Public License. If you find this application useful and wish to support its development, please consider purchasing a support subscription using the PayPal link below.

Options

17 comments:

  1. Got it up and running now. I really like the overhaul. Great work.

    ReplyDelete
  2. Thankx man, new version of conky manager works like charm in linux lite 2.0

    ReplyDelete
  3. Hi Tony - just installed 2.0.2 on LMDE and when I try to import a theme pack it says the import has occured, but the themes never show up anywhere.

    ReplyDelete
    Replies
    1. Hi Jon, did you try importing the official theme pack or some other pack?
      Theme packs created for previous versions will not work with this version.

      Delete
    2. I had a theme pack that was prepared for the previous version (it was labelled Deluxe_Conky_Theme_Pack.cmtp.7z). The new one works OK - is there a way to convert the old package or is it necessary to re-package it ?

      Delete
    3. Please wait a few days. I'll re-pack the old theme packs for this version.

      Delete
  4. up && running fine on Trusty thanks....

    ReplyDelete
  5. Reading package lists... Done
    ltdanno@super-computer:~$ sudo apt-get install conky-manager
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    conky-manager : Depends: libglib2.0-0 (>= 2.35.9) but 2.32.4-0ubuntu1 is to be installed
    Depends: libgtk-3-0 (>= 3.7.10) but 3.4.2-0ubuntu0.8 is to be installed
    E: Unable to correct problems, you have held broken packages.
    ltdanno@super-computer:~$
    LXLE 12.0.4 ANY ideas whats doing this

    ReplyDelete
    Replies
    1. There are some dependency issues with 12.04 based distros (like LXLE 12.04).
      Please update to a newer release.

      Delete
  6. PCLinuxOS 32 bit Mate
    ]$ ./conky-manager-latest-i386.run
    Verifying archive integrity... All good.
    Uncompressing Conky Manager (i386).....................................
    Installing files...
    ./install.sh: line 9: sudo: command not found
    Installation failed!

    ReplyDelete
  7. Sudo use only Ubuntu, other distribution uses su
    sudo can be installed in PCLinuxOS, Fedora, but for what ?

    ReplyDelete
  8. Hi
    I try to install conky manager 2 on fedora 20 and ubuntu - gnome14.04.1
    it is not able to install on fedora with this version and on the ubuntu it's good .
    ==========
    my question :
    I use more conky all like (conky seamod) when it loaded just cpu circle show on desktop
    but other circle and network meter don't work . when I remove line for cpu circle in config
    file then other circle work good .
    where is it this problem ? can you help me ?
    for best explain to you , I send a screenshot .

    https://www.dropbox.com/s/uir0iweqv8x8wwe/Workspace%201_006.png

    thank you

    ReplyDelete
    Replies
    1. I think you have a dual-core CPU.
      Conky Seamod tries to draw 4 rings for 4 cores and fails after drawing the 2nd ring for CPU.
      Edit the file 'seamod_rings.lua' and remove cpu2 and cpu3 values.
      Edited file is attached below:
      seamod_rings.lua

      Delete
    2. Hello
      I use it and work !!! thank u :)

      Delete
  9. Hello, the link for conky-manager-latest-amd64.run is not working, could you please re-upload it?
    Thank you.

    ReplyDelete
    Replies
    1. There were some issues with the installer. Updated installer will be uploaded soon.

      Delete
  10. Kali 1.0.8
    ..............
    dpkg: dependency problems prevent configuration of conky-manager:
    conky-manager depends on libglib2.0-0 (>= 2.35.9); however:
    Version of libglib2.0-0:amd64 on system is 2.33.12+really2.32.4-5.

    dpkg: error processing conky-manager (--install):
    dependency problems - leaving unconfigured
    Processing triggers for man-db ...
    Processing triggers for desktop-file-utils ...
    Processing triggers for gnome-menus ...
    Errors were encountered while processing:
    conky-manager

    ReplyDelete

If you are reporting an issue and commenting as an anonymous user, please leave your email address so that I can get in touch with you.