Conky Manager

Latest Version: 2.0 (2014-06-17)
Platform: Linux (Debian/Ubuntu)
Language: Vala & GTK3
ProjectPage: https://launchpad.net/conky-manager
PPA: https://launchpad.net/~teejee2008/+archive/ppa

Conky Manager

Conky Manager is a graphical front-end for managing Conky config files. It provides options to start/stop, browse and edit Conky themes installed on the system. Packages are currently available in Launchpad for Ubuntu and derivatives (Linux Mint, etc).

Features

  • Start/Stop, Browse and Edit Conky themes
  • Run Conky on system startup
  • Options to change location, transparency and size of Conky widget window
  • Options to change time and network interface

Screenshots


Themes

Most of the themes are from DeviantArt and the Eye Candy Linux community on Google+.

Gotham

Torn Paper Clone

CPU Panel

NVIDIA Panel

User Manual

A complementary user manual is now available for all users who have contributed to this project either through donations or by translating the application to other languages. The manual has a detailed description of the functionality along with steps required for creating theme packs and for fixing common issues.

If you wish to receive a copy of the user manual please consider leaving a donation using the PayPal link below. A copy will be sent to you by email. If you have already donated to this project you do not need to donate again.

Installation

Ubuntu-based Distributions (Ubuntu, Linux Mint, etc)

If you are using Ubuntu or its derivatives (like Xubuntu, Linux Mint, etc) you can install it from the Launchpad PPA. Builds are available for the following Ubuntu releases:

  • 13.10 (saucy)
  • 14.04 (trusty)
  • 14.10 (utopic)

For any other release, you can install it using the DEB files given below.

conky-manager-latest-i386.deb (32-bit, 1 MB)
conky-manager-latest-amd64.deb (64-bit, 1 MB)

To install from PPA, type the following commands one by one in a terminal window:

sudo apt-add-repository -y ppa:teejee2008/ppa
sudo apt-get update
sudo apt-get install conky-manager

Updates will be installed automatically if you have enabled automatic updates enabled on your system. The package can also be updated manually by running the install command again.

sudo apt-get install conky-manager

Debian

The DEB files are available from following links:

conky-manager-latest-i386.deb (32-bit, 1 MB)
conky-manager-latest-amd64.deb (64-bit, 1 MB)

Theme Packs

The default installation contains only a few sample themes. For more themes, download the theme pack given below and install it using the Import button on the toolbar.

Official Theme Pack #1 (15 MB)

Disclaimer

This program is free for personal and commercial use and comes with absolutely no warranty. The author will not be liable for any damages arising from the use of this program.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
See the GNU General Public License for more details.

Support This Project

This application is free for personal and commercial use and is licensed under the GNU General Public License. If you find this application useful and wish to support its development, please consider purchasing a support subscription using the PayPal link below.

Options

187 comments:

  1. Can you post some quick instructions on installing it in Fedora or other systems.

    ReplyDelete
  2. Currently only DEB files are available. The DEB file can be downloaded and converted to RPM using the alien utility: http://www.thegeekstuff.com/2010/11/alien-command-examples/

    ReplyDelete
    Replies
    1. Could cause the Conky used the following folder ".conky-manager"?

      Delete
    2. +1
      Better yet if there is an option to set-up my own path where keep conky manager files
      And BTW thanks guys for your excellent job,

      Delete
    3. Hello, i tried installing this on gentoo but im getting "conky-manager: error while loading shared libraries: libgee.so.2: cannot open shared object file: No such file or directory" any ideas?

      Delete
  3. amazing keep with the excellent work! ability to download configs from devianrt!

    ReplyDelete
    Replies
    1. De lujo mil gracias por el aporte camaradas.

      Delete
  4. This is the Best Conky app I have ever used.Thank you making this. I have made a video on this with my Conky Package that I have put together for this App. Thanks, Jesse Avalos

    Video
    https://www.youtube.com/watch?v=imUdL8e5jvE

    Super Conky Package
    https://docs.google.com/file/d/0B0eO_d_3xTouaE5JdkpZbktReFU/edit

    ReplyDelete
  5. but how can i uninstall this?!

    ReplyDelete
    Replies
    1. Run the following in a terminal window:
      sudo apt-get remove conky-manager

      The 'conky-manager' folder in your home directory has to be deleted manually.

      Delete
    2. yo lo tengo instalado en mi hp 64 bits pero no me deja editar los conkys... he intentado reinstalarlo y nada sigue con el problema... en ubuntu 13.4...

      Delete
  6. I'm using ubuntu 13.04 & cairo dock, and I configured correctly this both widgets on my DESKTOP:

    MaxConky - Black & White
    Nvidia Panel

    But when I click on desktop or open a Nautilus browser, them disappear.

    I paste below the config for Nvidia Panel, please help me !! :)

    # **********************************************************************
    # Simple theme for Conky by Tony George (teejee2008@gmail.com)
    #
    # Webpage: http://teejeetech.blogspot.in/
    # **********************************************************************

    background yes
    double_buffer yes

    alignment bottom_right

    border_width 1
    cpu_avg_samples 2
    default_color white
    default_outline_color white
    default_shade_color white
    draw_borders no
    draw_graph_borders yes
    draw_outline no
    draw_shades no

    gap_x 20
    gap_y 420
    net_avg_samples 2
    no_buffers yes
    out_to_console no
    out_to_stderr no
    extra_newline no

    own_window yes
    own_window_type normal
    own_window_transparent no
    own_window_colour 000000
    own_window_argb_visual yes
    own_window_argb_value 51
    own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager

    minimum_size 200 220

    stippled_borders 0
    update_interval 1.0
    uppercase no
    use_spacer none

    show_graph_scale no
    show_graph_range no

    use_xft yes
    xftalpha 0.1
    xftfont Ubuntu:size=10
    override_utf8_locale yes
    color0 white
    color1 EAEAEA
    color2 FFA300
    color3 grey

    TEXT
    ${color2}GPU Temp: ${alignr}${color0}${nvidia temp} °C
    ${color2}Fan Speed: ${alignr}${color0}${execi 5 nvidia-settings -q [fan:0]/GPUCurrentFanSpeed -t} %
    ${color2}GPU Clock: ${alignr}${color0}${nvidia gpufreq} MHz
    ${color2}Mem Clock: ${alignr}${color0}${nvidia memfreq} MHz
    ${color2}Mem Used: ${alignr}${color0}${execi 5 nvidia-settings -q [gpu:0]/UsedDedicatedGPUMemory -t} / ${exec nvidia-settings -q [gpu:0]/TotalDedicatedGPUMemory -t} MiB
    ${image ./nvidia.png -p 0,90 -s 200x132}




    ReplyDelete
    Replies
    1. Try changing own_window_type to desktop or conky

      Delete
  7. Works in Debian/Testing too. Instaled from PPA packages. Thanks.

    ReplyDelete
  8. Conky LSD theme appears on top of all windows when enabled. Using Ubuntu 12.04 and latest conky-manager 1.2 Haven't fiddled with the code settings, but is there one I can change to have it under other windows? Lovely theme - thanks!

    ReplyDelete
    Replies
    1. Find the following line in config file:

      own_window_hints undecorated,sticky,skip_taskbar,skip_pager

      change it to:

      own_window_hints undecorated,sticky,skip_taskbar,skip_pager,below

      Delete
    2. That's done it - thanks! I really must learn more Conky :)

      Delete
  9. Your work is amazing.
    I think it,s the best conky manager that now exists.

    ReplyDelete
  10. best conky manager out there, btw this now works on Manjaro + Arch Linux, here is the aur:
    https://aur.archlinux.org/packages/conky-manager-bzr/

    ReplyDelete
    Replies
    1. Thanks for the info! The install instructions have been updated for Arch Linux.

      Delete
    2. Yeah well I installed the program from the AUR and it works. However I downloaded the Deluxe Conky Theme Pack and it contains nothing. I tried it in different locations tried unzipping it tried importing via the program and it does nothing.
      I downloaded the Nvidia Panel separately and installed via the import on the program and it works just fine.
      Neat program. Guess I need to brush up my conky skills.

      Thanks.

      Abarbarian

      Delete
  11. I made a pkgbuild for stable version and another for bzr/trunk. I never used conky before, but with this conky-manager it's so easy... :-)

    https://aur.archlinux.org/packages/conky-manager/
    https://aur.archlinux.org/packages/conky-manager-bzr/

    ReplyDelete
  12. I installed conky-manager in Manjaro but the theme pack is not present, where I can get it? Thanks in advance. /Saverio

    ReplyDelete
    Replies
    1. Download the pack from the following link and import it using the Import button (see post above).
      Deluxe Conky Theme Pack

      Delete
  13. Thanks buddy tis is a great app :)

    ReplyDelete
  14. Hi all,

    "Run Conky at start-up" is already checked, but it won't load at startup on Ubuntu 12.04.I totally remove conky manager and re-installed it, but it doesn't work at all on startup.

    please anyone help me and sorry for my English. Thank you,

    ReplyDelete
    Replies
    1. sh -c "sleep 301s;

      you can enter this in your /home/yourname/conky-manager/conky-startup.sh file

      sh -c "sleep 301s; conky -c /home/yourname/conky-manager/themes/blue_vision/config/conkyrc" &

      but when you change your conky you will need to add this again.

      there are many ways to append this, this was the fastest for me

      Delete
    2. Hi, please un-check and check the checkbox for "Run Conky at system startup" and let me know if you can see a file named "Conky.desktop" in the following folder:

      ~/.config/autostart/

      Delete
    3. It needs to be delayed by a few seconds according to this
      http://askubuntu.com/questions/139722/conky-not-working-in-gnome-3-4

      Delete
  15. I try to do but after this command:
    sudo apt-add-repository -y ppa:teejee2008/ppa

    Traceback (most recent call last):
    File "/usr/lib/linuxmint/mintSources/mintSources.py", line 1202, in
    add_ppa_via_cli(ppa_line, codename)
    File "/usr/lib/linuxmint/mintSources/mintSources.py", line 32, in add_ppa_via_cli
    user, sep, ppa_name = line.split(":")[1].partition("/")
    IndexError: list index out of range

    No chance for me untill now, can you help me?

    ReplyDelete
    Replies
    1. Its

      sudo apt-add-repository ppa:teejee2008/ppa

      Delete
    2. Looks like a problem with your system. Are you able to install other packages?

      Delete
  16. Absolutely tremendous work. Works beautifully, thanks a bunch!

    ReplyDelete
  17. Very nice application. Going to feature it on my Linux blog.

    ReplyDelete
  18. Work like a charm in Elementary OS and Linux Mint 15 KDE.

    B E A U T I F U L L ;-)

    ReplyDelete
  19. Helo Guy! How do i make to configure weather on the Weather Theme?

    I Live in Parnaíba - Piauí - Brasil (BRAZIL)

    ReplyDelete
  20. Fantastic work, looks easy but it's original and really useful application!
    Thanks!!

    ReplyDelete
  21. Hi! Thks for great job! I have an issue with conky max4 from the package. Not starting at all on my elementary luna OS, intel graphics laptop!

    ReplyDelete
  22. OK I am not getting this. I followed the steps to install this on Xubuntu 12.04. There is no "conky" folder created anywhere and no way to launch the program...not sure what I am doing wrong lol.

    ReplyDelete
    Replies
    1. Have you installed Conky? Not Conky Manager, but just Conky?

      Delete
  23. thankyou,i'm a chinese linux user,Linux deepin a chinese distro of linux,please forgive my pool english,
    i found that the file on desktop can't delete,bug?

    ReplyDelete
  24. Should you wish to add my "Chalkboard" script to your collection, it is available here:
    http://treemagic.org/Chalkboard.tar.gz

    Enjoy.

    ReplyDelete
  25. Absoutely brilliant. Works great on Xubuntu 13.04. Many thanks for this.

    ReplyDelete
  26. Gold&Grey Modified again by karanik (Add Temp,System info,Network info,Weather,Open Ports)

    http://3.bp.blogspot.com/-8MdMG6xKzEQ/Uh8hmszzc7I/AAAAAAAAU1o/44D9I9JOzp0/s1600/conky+Gold%2526Grey+%2528karanik%2529.png

    DL : http://www.karanik.gr/2013/08/conky-manager-debian-themes-gold.html

    ReplyDelete
  27. Could cause the Conky used the following folder ".conky-manager"?

    ReplyDelete
  28. great app, but having problems with graphical elements of a conky not loading. the colorful clocks and data rings aren't loading, all other info is correct. i'm on manjaro with openbox wm.

    ReplyDelete
    Replies
    1. Check the config file of the theme that you are using. Most themes use lua scripts for drawing rings. If the path of the lua script is wrong in the config file then the rings will not be drawn.

      Delete
  29. Bonjourn je viens cet apres midi d'installer conky-manager et le "pack" supplémentaire
    tout a l'air de fonctionner parfaitement . Je tiens a vous signaler que j'avais , aussi , installé le programme conky-manager dans "Voyager 13.04 " ,très bon programme , merci et au plaisir , Jibel 8-))

    ReplyDelete

  30. Really awesome!

    I have another machine with gentoo running.

    Unfortunately, I could not find a configure script in source.

    Could you please provide it? I would love to compile and use it on other, not debian based distros, too.

    Thanks in advance,

    Torsten

    ReplyDelete
    Replies
    1. The makefile included with the source is very simple. Just replace the path variables and run the make install command in the same directory.

      Delete
    2. I would also appreciate a configure script. Your instructions to "replace the path variables" is, I'm afraid, too vague to be helpful. Where? I looked in "makefile" and didn't see any "path variables". Meanwhile, your included install instructions say: "Briefly, the shell commands `./configure; make; make install' should configure, build, and install this package."

      If you're not going to include a configure script, some among the less experienced would greatly appreciate a more concise set of instructions? FYI: I'm trying to compile your software for a Xubuntu system running on ARM.

      Delete
  31. exlente la aplicacion pero al parecer no va bien en ubuntu 13.4 64 bit....

    ReplyDelete
  32. not work well in ubuntu 13.4 64 bit I've tried it and does not leave edit any topic and works as you want

    ReplyDelete
  33. Thank you very much! I'm playing with conky-mamager on Manjaro with Mate now and it works perfectly!

    Best regards from Holland, Yogrt
    yogrt.org

    ReplyDelete
  34. Hi there,
    thanks for your job, really good one.

    I did install the manager on three machines, all Luna Elementary OS, on the 64AMD and 64PBell everything is perfect

    On the 3rd one, an HP pavillon, the "clock&data" theme can't show the network activities, nor the IP address nor the speed and so on.
    The Wifi section is on Wlan0 like the others but is non working.
    Any way to fix it? I would like to have the same one on all three, I need the network "counter" because they charge me the data amount.
    Thanks a lot
    Mariner

    ReplyDelete
  35. Hola:

    ¿En Sabayon se puede instalar Conky Manager?.

    Gracias.

    ReplyDelete
  36. can i manually edit the conky files

    ReplyDelete
    Replies
    1. Yes! The conky config files are kept under /home//conky-manager/themes/.
      You can edit the files with GEdit or any bother text editor.

      Delete
  37. Works like charm in Ubuntu 12.04 LTS x64. Thanx man!

    ReplyDelete
  38. Hello:

    How can install Conky Manager in Sabayon Linux?.

    Thank you.

    ReplyDelete
    Replies
    1. Currently only Debian/Ubuntu and ArchLinux packages are available.
      Next version will have an installer for installing on other Linux distributions.

      Delete
  39. I really love this app!. So much so that I have started a collection of themes for it. I have modified the themes to work directly in Conky Manager. Check them out! https://github.com/gld1982ltd/conky-manager-themes

    ReplyDelete
  40. you could get more conky themes from http://www.noobslab.com/

    ReplyDelete
  41. Hello.
    I am running a debian based system, (sparky linux) but i can't find a Deb file on launchpad.

    ReplyDelete
  42. I'm running Point Linux, which is based on Debian Wheezy. I'm getting:

    W: Failed to fetch http://ppa.launchpad.net/teejee2008/ppa/ubuntu/dists/wheezy/main/source/Sources 404 Not Found

    W: Failed to fetch http://ppa.launchpad.net/teejee2008/ppa/ubuntu/dists/wheezy/main/binary-amd64/Packages 404 Not Found

    ReplyDelete
  43. sudo add-apt-repository ppa:teejee2008/ppa deb-src http://ppa.launchpad.net/teejee2008/ppa/ubuntu raring main
    sudo add-apt-repository ppa:teejee2008/ppa deb http://ppa.launchpad.net/teejee2008/ppa/ubuntu raring main

    sudo apt-get update
    sudo apt-get install conky-manager

    sur linux mint 15 amdx64 pour moi ca à marcher nickel .

    ReplyDelete
  44. Hi,

    I am using Arch Linux from September 2013. When I try to install conky-manager-bzr I get the following output: http://pastie.org/8404888 (many lines, so I stored it at pastie).

    It leads to "==> ERROR: A failure occurred in build()."

    Maybe someone has a hint for me?
    Many thanks in advance!

    Patrick

    ReplyDelete
  45. Hi ,
    We try to package conky-manager into Fedora main repos, main conky-manager under GPL , what about (Deluxe Conky Theme Pack by Jesse Avalos) ??

    ReplyDelete
    Replies
    1. The Deluxe Conky theme pack contains themes from various sources/authors. Please contact the maintainer (Jesse Avalos) for more information.

      Delete
    2. Please dont remove pervous versions.

      Delete
    3. Fedora now has a package called conky-manager, congratulations!!

      http://mosaabalzoubi.wordpress.com/2014/10/25/conky-manager-to-fedora/

      Delete
  46. it is very good program... thanks.

    ReplyDelete
  47. Works well under Lubuntu 13.10. Conky Manager is really an example of superior work. Thank you for what you have done.

    ReplyDelete
  48. on crunchbang dont work.

    ReplyDelete
  49. Hi!
    It's possible to have more 8 core CPU in CPUPanel?
    Thanx you!

    ReplyDelete
  50. It needs some work for 2560x1600 screens!

    ReplyDelete
  51. Great with Crunchbang :)

    ReplyDelete
  52. You are God. I used to look at all the conky themes and salivate. Every time I tried to install it, one thing or the other went wrong. It is good to know that you are looking out for lesser mortals like me. I will spread Your word to everybody I meet -- at home, at work and on the street. Bless yourself!

    ReplyDelete
  53. Hello TG and everyone,

    Thank you for the impressive work really!
    I hope someone can give me a hand with an error that I am facing. When trying to install from the PPA repo it says that the decencies are not satisfied and i have to fulfill it manually: Conky-all and P7zip-full. Installed them both and tried to install again from the PPA but it gives me the same error;
    ======================== code =================
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    conky-manager : Depends: conky-all but it is not installable
    Depends: p7zip-full but it is not installable
    E: Unable to correct problems, you have held broken packages.
    ===================== END OF CODE ==================
    Any idea?
    Linux Mint 16 RC

    ReplyDelete
  54. Hello TG! Sorry for my bad english, but i have one question. Do you have plan support Fedora 20 In next version of Conky Manager? Thnkx for ansver.

    ReplyDelete
    Replies
    1. Yes, the next version will have an installer that can be used on Fedora and all other Linux systems. It will be released soon.

      Delete
    2. Txanx for reply and good luck with the this avesome project!

      Delete
  55. How to change default dir "conky-manager" to .conky_manager ?

    ReplyDelete
  56. Great work TG though small problem with weather not showing any info, do I need to config the weather rss that is in the same folder as the conkyrc?

    ReplyDelete
  57. Hi Tony, on my Ubuntu 12.04, "sudo apt-get install conky-manager" failed! E: Paket conky-manager not found.
    Can you fix this problem?

    ReplyDelete
    Replies
    1. https://bugs.launchpad.net/conky-manager/+bug/1204053

      Delete
  58. Hope there will be a version working with >vala-0.20 & gee-0.8 soon.

    ReplyDelete
  59. When will you add a PPA for 14.04 Trusty? (I'm testing Xubuntu 14.04 Alpha 2) I would like to test Conky Manager in 14.04. Of course I can download the DEB file or edit the repository source to "saucy" but it's always better to have the PPA enabled for updates. For Aptik you already have the Trusty PPA many thanks for that, Aptik is so good it should be in many distros by default. Anyway I really like your work and this blog. Best regards, Kaf

    ReplyDelete
    Replies
    1. Conky Manager v2 will be released soon for 14.04

      Delete
  60. Great app, thanks. I think /conky-manager folder should go /.conky-manager

    ReplyDelete
  61. How to import a custom conky theme into conky manager? For example, if i want to import conky eOS(http://karmaline.deviantart.com/art/Conky-eOS-388896731), how can i do it?

    ReplyDelete
    Replies
    1. Open the conky-manager folder & create folder 'conky eOS' Within that folder create another folder called config which contains the conkyrc. In other words the path must be ~/conky-manager/conky eOS/config/conkyrc and then 'refresh list' inside the conky manager. You can also put screenshot named 'preview.png' within the conky eOS folder. That worked for me. If there is any lua link or images, make sure the paths check out.

      Delete
  62. долго искал conky,и только через googl++ попал к вам на сайт.большое спасибо,действительно ЛУЧШАЯ ))

    ReplyDelete
  63. Hi! Really nice work. I installed rpm for opensuse 13.1, but cannot see widget drawings. Lines, cores, clocks and the like - I just see the plain text. Any hint?

    Vittorio

    ReplyDelete
    Replies
    1. Hi, I get a

      Conky: llua_load: /home/xXxXxX/.conky/cairosidebar/sidebar.lua:26: module 'cairo' not found:
      no field package.preload['cairo']
      no file './cairo.lua'
      no file '/usr/local/share/lua/5.1/cairo.lua'
      no file '/usr/local/share/lua/5.1/cairo/init.lua'
      no file '/usr/local/lib/lua/5.1/cairo.lua'
      no file '/usr/local/lib/lua/5.1/cairo/init.lua'
      no file '/usr/share/lua/5.1/cairo.lua'
      no file '/usr/share/lua/5.1/cairo/init.lua'
      no file '/usr/lib64/conky/libcairo.so'
      no file './cairo.so'
      no file '/usr/local/lib/lua/5.1/cairo.so'
      no file '/usr/lib64/lua/5.1/cairo.so'
      no file '/usr/local/lib/lua/5.1/loadall.so'

      Delete
  64. Great job on an awesome tool! However, I'm a little wary of downloading any DEB and installing it. Can you get it into the Debian repositories? I don't know if you can have it added to Wheezy, but I'm sure Jessie is open to new packages.

    ReplyDelete
  65. The Gold & Grey theme has a bug in the time widget: when I select 24-hour mode, it says (as it does at the moment): 16:20 PM. I don't know where else to report this.

    ReplyDelete
  66. Hi
    Great job. But when you add a dot to directory name of conky-manager? This catalog should be invisible.

    ReplyDelete
    Replies
    1. Will be fixed in the next update

      Delete
  67. Replies
    1. Package has been uploaded for Trusty. It should work now.

      Delete
  68. I am on Linux Mint 16. Do need to run Conky Manager in the background all the time for this to work. Whenever I click on the shortcut for "Desktop", Conky dissappears.

    ReplyDelete
    Replies
    1. You can close Conky Manager after starting the themes. Don't use the "Show Desktop" option. Just close the window normally.

      Delete
    2. The same her, even if i click options tab in Conky-manager , Conky disappears,
      System:
      Debian jessie 64bit with gnome3 Classic session.

      Regards

      Delete
  69. Please, release the App for Trusty Tahr.

    ReplyDelete
    Replies
    1. The old version is now available for Trusty.
      The new version will be released by end of this month.

      Delete
    2. Thank you very much!!!!

      Delete
  70. Great job Toni!!! I installed Conky Max 4 in Ubuntu 12.04 and works perfectly. Is it possible to add the name of the distribution?
    Thanks !!!!!!!

    ReplyDelete
  71. Great project! I will contribute with translation, but could you please pull a list of users from launchpad that have contributed and add it to the Conky Managers About-tab?

    ReplyDelete
    Replies
    1. Please wait till the next version is released instead of translating the existing template. I'll merge the existing translations and update the list.

      Delete
  72. Uma coisa que me chamou a atenção foi esse Conky 1.9.0, achei ele mais completo e funcional, mas, relendo por ai tem que efetuar várias configurações via terminal e eu ainda não domino muito bem, só algo mais leve via terminal.

    Baixei o arquivo Conky-1.9.0, esta na pasta Themes do Conky Manager, tentei instalar, mas, não abre, veja eese Conky pretendido abaixo

    http://vindsl.com/images/vindsl-desktop-29-may-2012-1.png

    Algo que errei aqui?

    ReplyDelete
  73. Uma coisa que me chamou a atenção foi esse Conky 1.9.0, achei ele mais completo e funcional, mas, relendo por ai tem que efetuar várias configurações via terminal e eu ainda não domino muito bem, só algo mais leve via terminal.
    One thing that caught my attention was this Conky 1.9.0, I found it more complete and functional, but rereading out there has to make various settings via terminal and I still domino fine, just something light via terminal.

    Conky-downloaded the 1.9.0 file, this in Conky Themes Manager folder, tried to install, but does not open, see below eese want Conky

    http://vindsl.com/images/vindsl-desktop-29-may-2012-1.png


    Something went wrong here?

    ReplyDelete
  74. I added the ppa successfully in Debian 7. Then apt-get update gives:

    "Failed to fetch http://ppa.launchpad.net/teejee2008/ppa/ubuntu/dists/wheezy/main/binary-i386/Packages 404 Not Found"

    Then of course: E: Unable to locate package conky-manager

    Is your repository still active?

    ReplyDelete
  75. I made a pkgbuild for stable version and another for bzr/trunk gambar payudara. I never used conky before, but with this conky-manager it's so easy... :)

    ReplyDelete
  76. Unity top panel shadow disappears with conky manager installed when all programs running are minimized until you click on the desktop then it returns. Ubuntu 13.10 and 14.04 64bit tested.

    ReplyDelete
  77. Solved myself by editing the config file for each one needed and changing to: own_window_type override, then setting the gui to display: Pseudo-Transparent for each one and then setting a startup delay for conky by adding: bash -c "sleep 15; (remove the quote from the original script beside the semi-colon you just typed or you'll get an error) to the startup command in startup applications and all is well now in Ubuntu 14.04

    ReplyDelete
  78. W: Failed to fetch http://ppa.launchpad.net/teejee2008/ppa/ubuntu/dists/wheezy/main/binary-i386/Packages 404 Not Found

    ReplyDelete
  79. Eric Chisholm21 May 2014 03:52

    conky-manager seemed to install and start fine, but every time I check one of the themes, it initially is checked, and then becomes unchecked, as it appears to fail to start one of the themes.

    running from the terminal shows "Error: Failed to execute child process "/tmp/1400623590.sh" (Permission denied)
    every time I check something

    any idea what to do?

    ReplyDelete
    Replies
    1. The temporary directory /tmp is mounted with 'noexec' option on your system. This prevents scripts from running from this directory. While this improves system security, it will cause problems for many applications which expect the /tmp directory to have execute permissions.

      To fix this, open /etc/fstab as root user, remove the 'noexec' option from the line for /tmp and reboot your system. This will allow scripts to run from the /tmp directory.

      I'll add a work-around for this in the next version of CM so that the user's home directory is used for storing temporary files.

      Delete
  80. nice app, I second previous suggestion of installing into ~/.conky-manager (hidden, directory)

    ReplyDelete
  81. Thanks so much for this. Total Linux newbie, and it got me up and running. Want to mess with configurations manually soon. Thanks!

    ReplyDelete
  82. don't work with mint 17 cinnamon and xfce. could you do something please?
    thank you!

    ReplyDelete
  83. Thanks for the great work!

    But I have a question:
    - I checked some widgets I like
    - I enabled "Run Conky at system startup"
    - An entry in ~/.config/autostart has been created (Exec=sh "~/.conky/conky-startup.sh")
    - But the file ~/.conky/conky-startup.sh does not exist

    Any ideas? It worked great before I updated CM to V2

    ReplyDelete
    Replies
    1. Which Linux distribution are you using?

      Delete
  84. The .deb file will not install on latest (updated) ElementaryOS (precise). It is complaining about held broken packages...??? Glib and Gtk3?

    ReplyDelete
  85. For some reason my old conky script is seen by CM and CM will generate a proper preview, but it is the only script that will not actually show up on my desktop. It worked in the previous version of CM. Any ideas?

    ReplyDelete
  86. Cannot upgrade from conky-manager 1.2.0.1 to 2.0.2 on Ubuntu 12.04.3
    Synaptic gives the following error:

    conky-manager:
    Depends: libglib2.0-0 (>=2.35.9) but 2.32.4-0ubuntu1 is to be installed
    Depends: libgtk-3-0 (>=3.7.10) but 3.4.2-0ubuntu0.8 is to be installed

    Seems like even though the PPA I'm trying to use is

    http://ppa.launchpad.net/teejee2008/ppa/ubuntu precise

    it's trying to upgrade to conky-manager 2.0.2~98~ubuntu13.10.1.
    Is that a PPA problem?

    ReplyDelete
    Replies
    1. i have the same problem in lxle 212.04.4 revisited....and im trying to install it for the first time

      Delete
    2. Please download the DEB file and install it. I'll fix this soon.

      Delete
    3. LXLE 12.04.4 revisited guy
      Thanks for the reply!
      I downloaded the .deb file (32-bit) but unfortunately I got the following in the Package Installer:
      Error: Dependency is not satisfiable: libglib2.0-0 (>= 2.35.9)
      any solutions?

      Delete
    4. Package for 12.04 is now available in PPA. Try installing again and let me know in case of issues.

      Delete
    5. Installed via terminal on LXLE 12.04.4 revisited, working fine so far, thanks for the help!

      Delete
  87. im installing conky-manager v2.0.2 in my Linux Mint 17 Cinnamon.. and im also download Deluxe themes pack..
    when i'm import Deluxe themes pack said "Themes Succesfully Import", but i not see new widget/themes.. whats wrong??

    ReplyDelete
    Replies
    1. Theme packs created for previous versions are not compatible with the new version. The theme pack needs to be modified.

      Delete
  88. same problem with deb pack
    conky-manager:
    Depends: libglib2.0-0 (>=2.35.9)

    ReplyDelete
    Replies
    1. Package for 12.04 is now available in PPA. Try installing again and let me know in case of issues.

      Delete
  89. I am getting Depends: libgtk-3-0 (>=3.7.10) but have installed latest version Package: libgtk-3-0 (3.12.2-1) on Wheezy. Any idea to solve this?

    ReplyDelete
    Replies
    1. Try using the installer.. links are given in above post

      Delete
  90. Hi Tony,

    This is an awesome upgrade to an awesome app!

    However, Unfortunately it doesn't play nice with my wife's laptop (LM17 Mate 64-bit).
    Once installed, and launched, it seems to hang on 'searching directories' and goes no further.

    On my partition, on the same laptop, I have no such issues (also LM17 Mate)

    Any help would be much appreciated!

    ReplyDelete
  91. When launched in terminal...

    chimelle@chimelle ~ $ conky-manager
    [19:34:35] Desktop: unknown
    [19:34:35] Found theme pack [installed]: /usr/share/conky-manager/themepacks/default-themes-2.0.cmtp.7z
    [19:34:35] App config loaded: '/home/chimelle/.config/conky-manager.json'

    (conky-manager:2964): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:2:16: Theming engine 'adwaita' not found

    ReplyDelete
  92. Baldrick,
    apt-get install gnome-themes-standard

    ReplyDelete
  93. Thanks Ferdinand,

    I did that, now I get this...

    $ conky-manager
    [18:55:17] Desktop: unknown
    [18:55:17] Found theme pack [installed]: /usr/share/conky-manager/themepacks/default-themes-2.0.cmtp.7z
    [18:55:17] App config loaded: '/home/chimelle/.config/conky-manager.json'

    ** (conky-manager:2479): WARNING **: Can't load fallback CSS resource: Failed to import: The resource at '/org/gnome/adwaita/gtk-fallback.css' does not exist

    ** (conky-manager:2479): WARNING **: Can't load fallback CSS resource: Failed to import: The resource at '/org/gnome/adwaita/gtk-fallback.css' does not exist


    Any idea how/where I can get gtk-fallback.css installed?

    Cheers.

    ReplyDelete
    Replies
    1. Looks like some files are missing from the Adwaita theme on your system....try selecting another theme from System Settings > Themes

      Delete
  94. At the moment I can't install conky-manager on Ubuntu 12.04 64-Bit, after adding the ppa the terminal output is: "Package not found". Trying to install the deb-package outputs the dependices can't be achieved ( libglib2.0-0 (>=2.35.9)).
    The PPA-Website says that a build failed, maybe that's the problem?
    Any other recommendations?

    ReplyDelete
    Replies
    1. Package for 12.04 is now available in PPA. Try installing again and let me know in case of issues.

      Delete
  95. Not able to install on Kubuntu 12.04.4:

    Vormals nicht ausgewähltes Paket conky-manager wird gewählt.
    (Lese Datenbank ... 199557 Dateien und Verzeichnisse sind derzeit installiert.)
    Entpacken von conky-manager (aus conky-manager-latest-amd64.deb) ...
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von conky-manager:
    conky-manager hängt ab von libglib2.0-0 (>= 2.35.9); aber:
    Version von libglib2.0-0 auf dem System ist 2.32.4-0ubuntu1.
    conky-manager hängt ab von libgtk-3-0 (>= 3.7.10); aber:
    Version von libgtk-3-0 auf dem System ist 3.4.2-0ubuntu0.8.
    conky-manager hängt ab von libjson-glib-1.0-0 (>= 0.13.2); aber:
    Paket libjson-glib-1.0-0 ist nicht installiert.
    conky-manager hängt ab von realpath; aber:
    Paket realpath ist nicht installiert.
    conky-manager hängt ab von conky-all; aber:
    Paket conky-all ist nicht installiert.
    dpkg: Fehler beim Bearbeiten von conky-manager (--install):
    Abhängigkeitsprobleme - verbleibt unkonfiguriert
    Trigger für desktop-file-utils werden verarbeitet ...
    Trigger für man-db werden verarbeitet ...
    Fehler traten auf beim Bearbeiten von:
    conky-manager

    Best regards.

    ReplyDelete
    Replies
    1. Package for 12.04 is now available in PPA. Try installing again and let me know in case of issues.

      Delete
  96. I had Conky Mangers working but now it just hangs on searching directories. I have un-installed and reinstalled but I keep getting the same issue. Any ideas cheers.

    ReplyDelete
  97. Hi,

    how i can remvoe the ./conky-manager-latest-amd64.run installation? My system frozed by Systemstart at line:
    Reached target Network after installation.

    This dosnt work:

    - sudo yum remove conky-manager
    - sudoc conky-manager --uninstall

    I need help please! Thx

    ReplyDelete
    Replies
    1. Sorry, im using Fedora 20 (x64). Let me tell how i can uninstall conky-manager - my system is broken after this installation. :-(

      My next test for the uninstallerfunction, dont want to help:

      - extract packet the install.sh to /tmp
      - ./install.sh --uninstall / & uninstall only --

      Thx for help!

      Delete
    2. Then i moved the folder /usr/share/conky-manager to a subfolder and change the name. And this dont work for me :(

      Delete
    3. Run the following commands to un-install:

      sudo rm -f "/usr/bin/conky-manager"
      sudo rm -f "/usr/share/applications/conky-manager.desktop"
      sudo rm -f "/usr/share/pixmaps/conky-manager.png"
      sudo rm -rf "/usr/share/conky-manager"
      sudo rm -f "/usr/share/locale/*/LC_MESSAGES/conky-manager.mo"

      Sorry for the late reply

      Delete
  98. cant install in debian jessie amd 64 dependency problems conky-all

    ReplyDelete
  99. Attention! Hands off installer script 'conky-manager-latest-amd64.run' ... It's buggy!!
    It sets the permissions from /usr, /usr/bin, and /usr/share to 700 on my Fedora20 x64... so GNOME can't start and no login with other users as root is possible on cmd! Please update quickly!!

    ReplyDelete
    Replies
    1. Here the same:

      After run the Install-Script:
      21-07 09:37] layer8@klapptop:~/Desktop]$ ssh layer8@10.0.0.37
      layer8@10.0.0.37's password:
      Last login: Sat May 24 05:15:57 2014 from klapptop.fritz.box
      /bin/zsh: Permission denied
      Connection to 10.0.0.37 closed.

      [21-07 09:37] layer8@klapptop:~/Desktop]$ ssh root@10.0.0.37
      root@10.0.0.37's password:
      Last login: Sat May 24 05:09:06 2014
      [root@TESTVM:~]#

      Delete
    2. I have removed links to the installer. I'm looking into this.

      Delete
  100. Great tool!!! Always hated conky because of the config. But now it becomes really easy.

    I converted the deb to rpm with alien to install on OpenSuse 13.1.

    Fonts are displayed but graphical elements (bars, diagrams etc. are missing. Why? Missing package?

    ReplyDelete
  101. Hi,
    I stumbled upon the same error as described by Juergen and ran into the same trouble. I think the source and target directory are swapped in the install.sh script.
    If you want to restore the file permissions on a rpm based system you might want to try this:
    for p in $(rpm -qa); do rpm --setperms $p; done

    Regards,
    Christian

    ReplyDelete
  102. Hi!
    There is a small bug in widgets. In configuration file there is a line "use_spacer yes". It's not a big deal but it causes warning. The line should be "use_spacer right". I've tested how it works using file .conky/Gotham/Gotham with replaced line and there's no more warnings. I think You can easilly fix this by replaceing that line in every file and it shoulndn't take much time.
    Greetings!

    ReplyDelete
    Replies
    1. Thank You for fixing the bug I reported. ;) Now my logs are clear.

      Delete
  103. Thank`s alot for usefull software

    ReplyDelete
  104. Can this be installed portable? I am trying to install this on my gentoo x64 system but I do not have a correct ebuild for it.

    ReplyDelete
    Replies
    1. Installation on Gentoo is currently not supported.
      You can try using the installer from following links:

      conky-manager-latest-i386.run (32-bit)
      conky-manager-latest-amd64.run (64-bit)

      Run it from a terminal window:

      ./conky-manager-latest-i386.run #32-bit
      ./conky-manager-latest-amd64.run #64-bit

      After the files are installed, install the following additional packages:
      conky p7zip imagemagick rsync libgee json-glib

      Delete
    2. Getting this crash now, everything built with support for jpeg, svg and png: http://paste.ee/p/orclv

      Delete
  105. Kali 1.0.8
    ..............
    dpkg: dependency problems prevent configuration of conky-manager:
    conky-manager depends on libglib2.0-0 (>= 2.35.9); however:
    Version of libglib2.0-0:amd64 on system is 2.33.12+really2.32.4-5.

    dpkg: error processing conky-manager (--install):
    dependency problems - leaving unconfigured
    Processing triggers for man-db ...
    Processing triggers for desktop-file-utils ...
    Processing triggers for gnome-menus ...
    Errors were encountered while processing:
    conky-manager

    ReplyDelete
  106. in kali 1.0.8
    The Version Conky-Manager-1.2.0.1 Work fine
    But Newer of Conky Manager "v2" Not Working .
    conky-manager depends on libglib2.0-0 (>= 2.35.9); however:
    Version of libglib2.0-0:amd64 on system is 2.33.12+really2.32.4-5.

    ReplyDelete
  107. conky-manager depends on libglib2.0-0 (>= 2.35.9);
    Issue has been resolved #Done
    Debian, Kali 1.0.8
    To fix the problem: Follow the steps:

    1) mkdir conky-manager && cd conky-manager
    2) mkdir -p conky-manager/DEBIAN
    3) dpkg -e conky-manager-latest-amd64.deb conky-manager/DEBIAN
    4) dpkg -x conky-manager-latest-amd64.deb conky-manager/

    In my case, Happened to me this error ( libglib2.0-0 (>= 2.35.9) ).
    So, I will Copy this error libglib2.0-0 (>= 2.35.9) Then;

    5) sed -i 's/libglib2.0-0 (>= 2.35.9)/libglib2.0-0/g' conky-manager/DEBIAN/control
    6) dpkg -b ./conky-manager conky-manager-latest-amd64.deb

    You should see this
    dpkg-deb: building package `conky-manager' in `conky-manager-latest-amd64.deb'.

    Finally:
    7) dpkg -i conky-manager-latest-amd64.deb
    8) apt-get -f install

    Problem ended.
    Note: Commands have been renumbered
    Problems mentioned in the previous replies, Follow the steps With changing the error
    Example :
    libgtk-3-0 (>= 3.7.10) # sed -i 's/libgtk-3-0 (>= 3.7.10)/libgtk-3-0/g' conky-manager/DEBIAN/control
    libglib2.0-0 (>= 2.35.9) # sed -i 's/libglib2.0-0 (>= 2.35.9)/libglib2.0-0/g' conky-manager/DEBIAN/control
    etc ...

    ReplyDelete
  108. Perfectly working on Xubuntu 14.04. Great upgrade of packages. Excellent job!!!!!

    ReplyDelete
  109. First of all: Nice piece of software!

    Second: Have the same problem as these two dudes here...

    ----------------------------------------------------------------------------------------------------------------------------------
    ----------------------------------------------------------------------------------------------------------------------------------

    # Clive Andrews13 July 2014 16:14

    I had Conky Mangers working but now it just hangs on searching directories. I have un-installed and reinstalled but I keep getting the same issue. Any ideas cheers.

    ----------------------------------------------------------------------------------------------------------------------------------

    # Baldrick10 July 2014 12:59

    Hi Tony,

    This is an awesome upgrade to an awesome app!

    However, Unfortunately it doesn't play nice with my wife's laptop (LM17 Mate 64-bit).
    Once installed, and launched, it seems to hang on 'searching directories' and goes no further.

    On my partition, on the same laptop, I have no such issues (also LM17 Mate)

    Any help would be much appreciated!

    ----------------------------------------------------------------------------------------------------------------------------------
    ----------------------------------------------------------------------------------------------------------------------------------

    ...it was always running fine - suddenly stopped working and the conky-manger is loading till death... looking forward to come over this error to roll the software out on many clients ;)

    Thanks a lot for the work and effort you put in this nice project!

    ReplyDelete
  110. Since this is the most active place for conky-manager discussions, I want to add it here as well:

    Ubuntu 14.10 Utopic has deleted the conky-all package on which conky-manager depends. I think they merged it with the conky package. What's the best way to handle this? Since you updated conky-manager ppa since they deleted conky-all, there should be a way around this.

    ReplyDelete
    Replies
    1. It is quite easy with the recipe above to just

      1) mkdir conky-manager && cd conky-manager
      2) mkdir -p conky-manager/DEBIAN
      3) dpkg -e conky-manager-latest-amd64.deb conky-manager/DEBIAN
      4) dpkg -x conky-manager-latest-amd64.deb conky-manager/
      5) sed -i 's/conky-all/conky/g' conky-manager/DEBIAN/control
      6) dpkg -b ./conky-manager conky-manager-latest-amd64.deb

      and install the package:

      7) dpkg -i conky-manager-latest-amd64.deb
      8) apt-get -f install

      Question is: what am I missing by replacing conky-all with conky?

      Delete
  111. If you are reporting an issue and commenting as an anonymous user, please leave your email address so that I can get in touch with you!!!


    IT WAS NICE NICE BUT IT STOPPED WORKING

    Linux Mint 17 XFCE

    ..worked like a charme for a couple of weeks and then stopped (I think i f**ked up the settings)...

    Now it's never "stopps" loading...


    NICE TRY EVEN THOUGH DUDE!

    NO PATCH ANYMORE?

    ReplyDelete
  112. Thank you for this great software.

    I'm using conky-manager 2.2~118~ubuntu14.04.1
    Pls help me understand why my brand new ~/.conky/conky-startup.sh contains this two statements:
    sleep 10s
    killall conky

    Thank you.

    --
    gianluca.santoro at gmail.com

    ReplyDelete
    Replies
    1. Hi,

      Have you selected some widgets from the Conky Manager window?

      Select some widgets, enable the option "Start at system startup" from Application Settings and then exit the application, The startup script will be updated.

      The startup script will kill running Conkys before starting the ones that you selected.
      The 10 second delay is required by Gnome desktop for Conky to start properly

      Delete
  113. Thank you very much Tony, all worked like a charm.

    ReplyDelete
  114. Congratulations, I have included banshee art, and has worked very well!

    ReplyDelete
  115. Im getting "./conky-manager-latest-amd64.run: line 488: ./install.sh: Permission denied" on gentoo, kinda lost here any ideas?

    ReplyDelete
    Replies
    1. run it with 'su' or 'sudo' command:

      sudo ./conky-manager-latest-amd64.run
      su -c ./conky-manager-latest-amd64.run

      Delete
  116. for anybody interested in installing this on wheezy DO NOT download the given binaries from above, download the ubuntu 12.04.1 .deb rom ppa (https://launchpad.net/~teejee2008/+archive/ubuntu/ppa/+packages) instead as the libglib dependency would not be met (unless you would like to built those from source). Install and enjoy! Cheers, Chris. P.S.: @TeeJee THANKS for the great work!

    ReplyDelete
  117. How do I go about configuring the them that has the rss reader on it? When I activate the theme there is no news displaying?

    ReplyDelete
  118. I have an issue, accidently added ~ to search directories now cannot open app it just continually searches, i cant stop it iv uninstalled and removed the config files ect re installed and same thing just sits there sreaching, how can i stop this?

    ReplyDelete
    Replies
    1. Delete the following file. It should fix the issue.
      ~/.config/conky-manager.json

      Don't add ~ to search list. There are too many files under this path.

      Delete
  119. hey just a question I have downloaded Conky but I have an issue whenever I try to add any theme all the themes end up in the widget tab, any suggestion?

    ReplyDelete

If you are reporting an issue and commenting as an anonymous user, please leave your email address so that I can get in touch with you.